
1 GET ACCESS TO YOUR LINKEDIN COMPANY PAGE

Have someone on your team who already has 
Company Page permissions grant you Super Admin 
access to the Page in order to create ads for all ad 
types. If you don’t already have a Company Page, 
you’ll need to create one.

SET UP CONVERSIONS

After completing Step #4, track when users complete 
a certain goal after clicking on your LinkedIn Ads by 
creating what’s called a Conversion.
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2 GET ACCESS TO YOUR LINKEDIN ADS ACCOUNT

Have someone on your team who already has 
Account Manager permissions grant you either 
Account Manager or Campaign Manager access to 
the company’s Ad Account. If you don’t already have 
an Ad Account, you’ll need to create one.

CONSIDER YOUR TARGET AUDIENCE

Define your audience by starting with a base targeting 
criteria and then layering on additional criteria to 
niche down.
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3 SET UP BILLING

Set up your Ad Account with credit card information in 
order to run ads. Note that only the Account Manager 
listed on the Account as the Billing Admin can 
complete this step.

SET UP CAMPAIGNS THE RIGHT WAY

Create LinkedIn Ad campaigns based on the audience 
you’ve defined. Uncheck Audience Expansion, bid by 
clicks to start, and avoid bidding too high.
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4 INSTALL THE LINKEDIN INSIGHT TAG

Install the LinkedIn Insight Tag on every page of your 
website. This will allow you to track conversions, 
enable retargeting audiences, and provide free 
professional demographics on your website traffic.

GET ACCESS TO YOUR LINKEDIN COMPANY PAGE

In the beginning stages of your LinkedIn Ads strategy, 
build affinity for your brand through ads that either 
add value and build relationships through content or 
educate on who you are and what problems you 
solve.
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THE COMPREHENSIVE LINKEDIN ADS STARTUP CHECKLIST

STEPS TO GET YOU STARTED
14 STEPS TO HIGH PERFORMING LINKEDIN ADS



9 CRAFT YOUR MESSAGE

Write ad copy that addresses a customer pain point, 
offers a solution, and includes a call-to-action. A/B 
test between different variations of messaging to find 
which resonates most with your audience.

PLAN A HOLISTIC LINKEDIN ADS STRATEGY

Plan a holistic LinkedIn Ads strategy tailored to the 
B2B buyer’s journey. Structure it around three stages: 
Build Awareness, Build Trust, and Build Advocacy.
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10 GATHER IMAGERY FOR YOUR ADS

Imagery should stand out and draw attention to your 
message. Try to avoid colors that would blend in with 
LinkedIn’s color scheme, like blues and whites.

CREATE MATCHED AUDIENCES

Build Matched Audiences that can be retargeted later 
in your holistic LinkedIn Ads strategy. Create them 
early so they have time to build and collect data.
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11 LAUNCH YOUR ADS

Combine the offer, messaging, and imagery that you 
put together to launch ads in the campaigns you 
created previously.

OPTIMIZE AND SCALE

Keep a close eye on ads as they run and make 
changes if performance isn’t up to par. Use resources 
like the podcast and blog found at b2linked.com for 
helpful LinkedIn Ads tips and tricks.

14

ADDITIONAL STEPS (RECOMMENDED)



THE COMPREHENSIVE LINKEDIN ADS STARTUP GUIDE

STEPS TO GET YOU STARTED
14 STEPS TO HIGH PERFORMING LINKEDIN ADS

1 GET ACCESS TO YOUR LINKEDIN COMPANY PAGE
Before you can even create ads on LinkedIn Campaign Manager, you 
first need permissions to access/manage your LinkedIn Company 
Page. To do this, have someone who already has Super Admin access 
add you as a Super Admin (you can also run ads with the role of 
Sponsored Content Poster under Paid Media Admins, but you’re limited 
to the Sponsored Content ad type).

There are two ways someone can add you to the Company Page. One is 
to do so from the Page itself. To do so, they must first go to the Page 
and then click Admin Tools > Manage Admins > Add Admin. Next, have 
them search for you in the pop-up box and assign you to the Super 
Admin role.

Before you can even create ads on LinkedIn Campaign Manager, you first need permissions to 
access/manage your LinkedIn Company Page. To do this, have someone who already has Super 
Admin access add you as a Super Admin (you can also run ads with the role of Sponsored Content 
Poster under Paid Media Admins, but you’re limited to the Sponsored Content ad type).

There are two ways someone can add you to the Company Page. One is to do so from the Page itself. 
To do so, they must first go to the Page and then click Admin Tools > Manage Admins > Add Admin. 
Next, have them search for you in the pop-up box and assign you to the Super Admin role.

The other is to add you from LinkedIn’s Business Manager. To do so, they must first go to Business 
Manager and then click Pages > the name of the page > Add People. Then, have them click Assign 
Role next to your name and assign you to the Super Admin role.

Note that this second option only works if you’re already added to your company’s Business Manager. 
If you’re not on Business Manager, any admin can add you by going to People > Invite People. Then, 
they can search for you via an email address and click Invite.

For more on Business Manager and how to create one for your company, click here:
https://business.linkedin.com/marketing-solutions/business-manager

Also, if your company doesn’t already have a Page, you can create one here:
https://www.linkedin.com/company/setup/new/



4 INSTALL THE LINKEDIN INSIGHT TAG
This is a crucial step to setting up your LinkedIn Ads. In order to track conversions on your website, 
enable website retargeting audiences, and get access to free professional demographics data on your 
website traffic, this tag needs to be installed properly.

To install the tag, go to your LinkedIn Ads Account and click Analyze > Conversion Tracking > Manage 
Insight Tag > See Tag. From here, there are a few different methods of installing it. We recommend 
clicking on the option “I will install the tag myself”.

Next, copy the code and paste it in your website’s global footer, right above the closing HTML <body> 
tag. Installing it here allows you to track conversions or retarget across any page of your website. If 
you don’t want to go through the hassle of delving into your website’s code, you can also install and 
set up the tag to fire on all pages of your website via Google Tag Manager.
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3
SET UP BILLING
If your organization has not yet set up your Ad Account with 
credit card information, you’ll need to do that before LinkedIn 
will allow you to run ads. Note that only the Account Manager 
listed on the Account as the Billing Admin can complete this 
step.

To do this, click the Account name in the top right of the 
navigation bar, then click Billing Center. From there, click Add 
Credit Card, fill in your credit card information, and click 
Review Order.

GET ACCESS TO YOUR LINKEDIN ADS ACCOUNT
Similar to Step #1, you can’t yet create campaigns or ads until you also have permissions to 
access/manage your company LinkedIn Ads Account. To do this, have someone within your 

organization who already has Account Manager access add you to the Account.

They can again do this one of two ways. One is through Campaign Manager. To do this, they must first 
go to the Account in LinkedIn Campaign Manager. From there, have them click the Account name in the 
top right of the navigation bar, then click Manage Access > Add User. Next, have them search for you in 

the pop-up box and assign you to the Account Manager or Campaign Manager role. Then click Add.

The other option can once again be done through LinkedIn Business Manager. To do so, have them go 
to your company’s Business Manager and click Ad Accounts > the name of the account > Add People. 

From there, they can then click Assign Role next to your name and either assign you to the Account 
Manager or Campaign Manager role. Then click Add.

If your company doesn’t already have an Ads Account, you can create one here: 
https://business.linkedin.com/marketing-solutions/ads



6 CONSIDER YOUR TARGET AUDIENCE
The reason why we’re willing to pay a premium on LinkedIn Ads is 
because of the platform’s targeting potential for B2B companies. 
This is, by far, the best part. Aside from targeting by Location and 
Profile Language (the first two steps to defining your audience), 
there are 30 different categories of criteria you can play with.

We recommend starting with a base targeting criteria and then 
layering on additional criteria to further define your audience. For 
example, if your target audience has roles in Human Resources, 
then you might select HR-related skills or the HR job function as 
your base targeting criteria. You could then layer on additional 
criteria, such as seniority and industry, after that.

We also recommend segmenting your audience. For example, if you want to target users with varying 
levels of seniority or companies of varying sizes, consider breaking your audience up into more than 
one campaign. When setting up your targeting in this way, you can essentially get focus group-level 
insights than if you were to lump targeting all together in one or two campaigns.
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SET UP CONVERSIONS

If you want to track when users complete a certain goal 
after clicking on your LinkedIn Ads, you can do so by 
creating what’s called a Conversion. Note that you’ll 

need to complete Step #4 first in order to do this.

To create a Conversion, go to your LinkedIn Ads Account and click Analyze > Conversion Tracking > 
Create Conversion > Online Conversion. What follows is a 3-step setup process which includes 
naming your Conversion, assigning an attribution model, selecting which campaigns you’d like to track 
the Conversion, and defining your conversion tracking method.

We recommend tracking conversions by Page Load via the LinkedIn Insight Tag. This is by far the 
easiest method and requires a Thank-You page (with a unique Thank-You page URL) for the goal 
you’re trying to measure. Simply copy your Thank-You page URL and paste it in the available box in the 
final step of the 3-step Conversion setup process.

For best results, we recommend changing the “starts with” parameter to “contains” and only including 
the snippet of your Thank-You page URL that is unique and distinguishes it as the Thank-You page.



8 CONSIDER YOUR OFFER
Before you create your ads, you need to consider what it is you’re going to offer your target audience. 
Your offer is a combination of the thing you’re promoting and your call-to-action (what you’re asking 
your target audience to do).

95% of the time, a cold audience isn’t willing to convert on something low-funnel, like a Demo Request. 
You need to warm your audience up first before they’re ready to buy in, so the perceived value of your 
starting offer needs to outweigh its perceived friction.

Promote an offer that teaches your audience something new, solves a major pain point, or helps them 
do their job better in some way. This can be done by educating them on the problems your business 
solves, who you service, and how you’re different from the competition with the call-to-action to learn 
more. It can also be done through assets that add value and build relationships like eBooks, webinars, 
podcasts, online communities, etc.

This is, by far, the most important part of your LinkedIn Ads strategy.

We also recommend bidding lower than LinkedIn’s recommended bidding 
range, as this often results in needlessly high costs. We suggest starting out 
bidding low and, if your campaigns are having a hard time spending their full 

daily budgets, incrementally increase your bids from day to day.

The final step is to attach a Conversion to your campaign, if you didn’t already 
do this in Step #5. Once finished, either Save and Exit or click Next if you want 

to move on to creating ads.
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SET UP CAMPAIGNS THE RIGHT WAY

Once you have an idea of the audience you want to target, the next step is to create campaigns. In 
LinkedIn Campaign Manager, first click on your Ad Account and then select the Campaign Group you’d 

like to create campaigns in (this can be the Default Campaign Group or you can create a new one).

Next, click the blue “Create” button on the left side. Select your campaign objective and start
defining your target audience. At the bottom of the Audience section is a little checkbox

titled “Enable Audience Expansion”. For best results, uncheck this box.

Next, select your ad format and ad placements (if applicable). Following these
steps will be setting up your campaign budget, bidding strategy, and
campaign schedule. As a general rule, we recommend your bidding

strategy be optimized for clicks and bidding under the Manual
Bidding option.



10 GATHER IMAGERY FOR YOUR ADS
The purpose of imagery on LinkedIn is to 
stand out and draw attention to your overall 
ad message. For this reason, we recommend 
avoiding colors that would blend in with 
LinkedIn’s color scheme, such as blues and 
whites.

Instead, use colors in your imagery that “pop” 
on the platform, like reds, greens, oranges, 
and yellows. We’ve seen all different types of 
imagery perform well, so conduct tests to 
find which of your images work best!

9
CRAFT YOUR MESSAGE

Once you’ve selected your offer, you’re ready to start crafting 
your ad messaging. When writing ad copy on LinkedIn, just 
like any digital ad platform, you want to communicate your 

message in a way that addresses a pain point.

Identify what it is your target audience struggles with, what 
challenges they face, and how your offer is a solution to 

those problems. Revolve your ad copy around that pain point 
and solution. Somewhere in your ad copy, be sure to also 

include a clear call-to-action.

We also recommend A/B testing different variations of ad 
messaging to find which variation resonates with your 

audience the most and which drives results.

DYNAMIC ADS

Headline - 50 characters
Description - 70 characters

SPONSORED MESSAGING ADS

Subject - 60 or fewer characters
Message - 1500 or fewer characters

TEXT ADS

Headline - 25 characters
Description - 75 characters

SPONSORED CONTENT

Intro - 150 or fewer characters
Headline - 70 or fewer characters

Text &
Dynamic Ads

100 x 100

Sponsored
Messaging
300 x 250

Sponsored
Content

1200 x 627



LAUNCH YOUR ADS
The moment you’ve been waiting for! To build your ads, 
go back to the campaigns you created in Step #7. Click 

the three dots next to the campaign name and select 
Edit. Then click the blue “Next” button below the 

Conversion tracking section.

From here, click “Create new ad”. Craft your ad by typing 
up your ad copy, uploading your creative, pasting in your 

destination URL (if applicable), and naming your ad. 
When you’re finished, click the blue “Create” button. 
Repeat this process if there are more ads in a given 

campaign you want to create.

Click the blue “Next” button at the bottom of your list of 
newly drafted ads, then click “Launch Campaign”.

If your audience is just hearing about you for the first time, it’s unlikely that they’ll want to buy your 
high-ticket product or service after seeing one or two ads from you. You’ll need to plan a holistic 
strategy in order to see a positive ROI.

Our holistic approach to LinkedIn Ads is divided into three stages, tailored to the way B2B consumers 
buy online today: Build Awareness, Build Trust, and Build Advocacy. If you’re just starting on LinkedIn 
Ads, chances are you’ll first execute your strategy at the Awareness Stage, but it’s important to have a 
holistic view of where you want your efforts to go from the beginning, so you can plan ahead.

Here’s how you can plan at each stage:

Build Awareness: At this stage, thought leadership and education are of the utmost importance. It’s 
about reaching your prospects where they are and positioning your brand as the only reasonable 
solution to their problems. It may require leveraging content like podcasts, newsletters, blogs, 
eBooks, checklists, live streams, etc to create demand for your products and services. Brand 
positioning (who you service, how you’re different, what problems you solve, and how your product 
works) needs to be strong here.

The first 11 steps were to simply help you get started on LinkedIn Ads as quickly as possible. However, 
there are a few more things you might want to consider doing before getting ads up and running.

Here are 3 more crucial steps to getting started on LinkedIn Ads:
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11

ADDITIONAL STEPS (RECOMMENDED)

PLAN A HOLISTIC LINKEDIN ADS STRATEGY



Build Trust: This stage is focused on helping your warm audience build confidence in your company 
and solutions. It leverages paid retargeting methods to further promote your business as the only 
reasonable solution to their unique challenges and encourages them to take the next step, such as 
booking a demo or consultation, starting a free trial, etc. It leverages social proof, like boosted 
high-engagement posts, customer reviews, case studies, stats, and more, to accomplish this

Build Advocacy: This stage is focused on increasing momentum by engaging current customers, 
company page followers, and other brand advocates, and encouraging them to leave online reviews, 
educating them on new product features or services, helping them feel included in your company 
culture / community, etc. It requires closely working with Customer Experience reps and continuing 
to deliver value through organic and paid efforts, exponentially increasing brand engagement, reach, 
and word of mouth online..

To execute a holistic LinkedIn Ads strategy, you’ll need to 
set up Matched Audiences to retarget later.

To do so, click Plan > Audiences > Create Audience. From 
the dropdown, select which type of retargeting audience 
you’d like to create. You have options to retarget by website 
traffic, Single Image Ad clicks, video views, and more.

As your LinkedIn Ads run, your audience(s) will build. Note 
that, as with both audiences created this way and through 
LinkedIn’s native targeting, the platform requires an 
audience size of at least 300 people in order to run a 
campaign. So you’ll need to allow time for your retargeting 
audience(s) to build in order to use them in your advertising 
efforts.

Also know that Matched Audiences built from website 
traffic cannot be built retroactively and require the Insight 
Tag to be installed properly. So create the Matched 
Audience and install the tag as early as possible in order to 
collect enough data for LinkedIn to create an audience 
around.

When building a website retargeting audience, we recommend changing the “starts with” parameter to 
“contains” and only including the snippet of your URL that is unique and distinguishes it from all other 
web pages (similar to what was mentioned in Step #5).
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CREATE MATCHED AUDIENCES



OPTIMIZE AND SCALE 
Once ads are live, you’ll need to keep a close eye on them to 

ensure they’re performing well. All prior steps were to help you get 
started on LinkedIn Ads, but you’ll need additional knowledge and 

tools if you want to see long-term success.

The good news? This Checklist is just the tip of the iceberg. We 
have loads of resources available to help you get the most out of 
LinkedIn Ads. Check out the blog and podcast on our website for 

more helpful LinkedIn Ads tips and tricks.

Website: https://b2linked.com/

Also, if you want to get more sales opportunities with your ideal 
prospects but don’t have the time or motivation to manage 
LinkedIn Ads yourself, B2Linked specializes in helping B2B 

companies grow through custom-tailored LinkedIn Ads strategies.

We differ from other agencies because we’ve solved the LinkedIn 
Ads paradox—We create efficiency by maximizing ROI and 

reducing costs at the same time.
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Book a Discovery Call with a LinkedIn Ads expert today: https://b2linked.com/apply

Cheering you on in your LinkedIn Ads initiatives!


